Firefox Browser Critical Flaw Could Cause Your System to Get Hacked

Mozilla has recently released a new patch to upgrade its web browser (Firefox) against vulnerabilities that could allow hackers to hack the browser remotely.
 
Affected Browser Version
 
Firefox 56 (.0, .2.1, .0.2), 57 (.0, .2.1, .2.2, .2.3, .2.4), and 58 (.0) were said to be affected due to this flaw. You are advised to use the latest version of Firefox (58.2.1), to safeguard against this and other potential hazards.
 
Follow this link for instructions on how to get the patch:

Contact Information

Joseph Koval –President
845-608-2505
13 Tomkins Ridge Rd.
Tomkins Cove, NY 10986

Follow us